Opened 9 years ago

Closed 5 years ago

#775 closed defect (fixed)

Unable to transcode Flac file

Reported by: little_gritche Owned by:
Priority: normal Milestone: 1.1 bugs
Component: Stream output Version:
Severity: major Keywords: flac, sout
Cc: xtophe Difficulty: unknown
Platform(s): Windows Work status: Not started

Description

Using VLC 0.8.5 on WinXP SP2

i'm trying to transcode a flac file but doing so, i am unable to hear the sound from the file.

I have these information in the messages :
"stream_out_transcode debug: drift is too high, resetting master sync"

I am using all those options to transcode it :

  sout=#transcode:std
  transcode:std
  sout-transcode-ab=384
  sout-transcode-acodec=mpga
  sout-transcode-channels=2
  sout-transcode-vt=1000000
  file-caching=300

Without any transcoding, VLC plays it just fine. Transcoding MP3 with those options works just fine also.

This problem is always reproducable.

Thanks

Change History (8)

comment:1 Changed 9 years ago by little_gritche

  • Keywords flac sout added
  • Milestone set to 0.8.5-final
  • Severity changed from normal to major

comment:2 Changed 9 years ago by little_gritche

I have to add that using a nightly build of VLC 0.8.6 from "branch-20061005-1609" for Windows, I have those messages :

main warning: buffer is 64196 in advance, triggering downsampling
main warning: audio drift is too big (-122450), clearing out
main warning: timing screwed, stopping resampling
main warning: audio drift is too big (-122267), clearing out
main warning: mixer start isn't output start (-56087)
main warning: buffer is 57711 in advance, triggering downsampling
main warning: timing screwed, stopping resampling
main warning: buffer is 103900 in advance, triggering downsampling
main warning: audio drift is too big (-153560), clearing out
main warning: timing screwed, stopping resampling
main warning: mixer start isn't output start (-12943)
main warning: audio drift is too big (-153378), clearing out
main warning: buffer is 52541 in advance, triggering downsampling
main warning: timing screwed, stopping resampling
main warning: buffer is 108061 in advance, triggering downsampling
main warning: audio drift is too big (-160600), clearing out
main warning: timing screwed, stopping resampling
main warning: mixer start isn't output start (-10463)
main warning: audio drift is too big (-160418), clearing out
main warning: buffer is 55829 in advance, triggering downsampling
main warning: timing screwed, stopping resampling
main warning: buffer is 110725 in advance, triggering downsampling
main warning: audio drift is too big (-158209), clearing out
main warning: timing screwed, stopping resampling
main warning: mixer start isn't output start (-11303)
main warning: audio drift is too big (-158026), clearing out
main warning: buffer is 51906 in advance, triggering downsampling
main warning: timing screwed, stopping resampling
main warning: buffer is 107165 in advance, triggering downsampling
main warning: audio drift is too big (-166417), clearing out
main warning: timing screwed, stopping resampling
main warning: audio drift is too big (-166235), clearing out
main warning: mixer start isn't output start (-75311)
[...]

comment:3 Changed 9 years ago by little_gritche

  • Milestone changed from 0.8.5-final to 0.8.6

comment:4 Changed 9 years ago by little_gritche

Hello,

I have made new tests using VLC 0.8.6 nightly build from 27/10/2006

I can also see this issue following those steps :

(the labels may be different because my VLC installation is french)

using the transcoding assistant :

  1. transcoding option
  2. selecting the flac file
  3. selecting the option "audio transcoding" with the codec "MPEG Audio" (rate 192 kbps)
  4. MPEG TS encapsulation
  5. selecting a destination file and clicking finish

After the operation finished, when I play the file resulting from the transcoding, no sound is outputted.

Thanks

comment:5 Changed 9 years ago by xtophe

  • Cc xtophe added

comment:6 Changed 8 years ago by hartman

  • Milestone changed from 0.8.6 to 0.9.0 bugs

comment:7 Changed 7 years ago by cmedia

Suggest trying patch from ticket#1953

comment:8 Changed 5 years ago by courmisch

  • Resolution set to fixed
  • Status changed from new to closed

Resampling in stream output was totally flawed in 0.8-1.0. It should be fixed in 1.1.

Note: See TracTickets for help on using tickets.