Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#762 closed defect (fixed)

video codec not recognized in flv

Reported by: larryy Owned by:
Priority: normal Milestone:
Component: Decoders Version:
Severity: normal Keywords:
Cc: Difficulty: unknown
Platform(s): all Work status: Not started

Description

Download the following:

curl -o InnerLifeOfACell.flv http://aimediaserver.com/studiodaily/harvard/harvard.flv

Try to play it. VLC 0.8.5 (both PowerPC as a Rosetta app and the newest Universal app on an Intel MacBook? Pro 17" 2.16GHz Core Duo running OS X 10.4.7, Build 8J2135) reports:

main: no suitable decoder module for fourcc `undf'. VLC probably does not support this sound or video format.

(Full Messages log below.)

Audio plays, but there is no video.

This same file plays video in flv_video_player.app (8.0 r22), flv_viewer_0.4.osx.app (10.1.1), flv_Wimpy FLV Player.app, and FLVPlayer_Sorenson.app, but lags horribly in all of them.

The video also plays fine in the Flash plug-in in Safari if you launch it by clicking the "High" button on <http://www.studiodaily.com/main/searchlist/6850.html>.

VLC is a great resource. I hope you can get this sorted.

(There were no bugs filed containing undf. I found a thread mentioning what might be a related problem--at least it mentioned this undefined video codec--but there was no hint of a resolution.)


Complete Message log follows:

main debug: CPU has capabilities 486 586 MMX MMXEXT SSE SSE2 FPU
main debug: looking for memcpy module: 3 candidates
main debug: using memcpy module "memcpymmxext"
main debug: waiting for thread completion
main debug: thread 34496000 (playlist) created at priority -47 (playlist/playlist.c:184)
main debug: waiting for thread completion
main debug: thread 33759232 (preparser) created at priority -47 (playlist/playlist.c:210)
main debug: looking for interface module: 1 candidate
main debug: using interface module "hotkeys"
main debug: thread 33659392 (interface) created at priority -47 (interface/interface.c:198)
main debug: looking for interface module: 3 candidates
main debug: using interface module "macosx"
main debug: thread 34534912 (manage) created at priority -47 (interface/interface.c:164)
main debug: adding playlist item `InnerLifeOfACell.flv' ( /Users/larryy/Movies/InnerLifeOfACell.flv )
main debug: creating new input thread
main debug: waiting for thread completion
main debug: thread 35089408 (input) created at priority 37 (input/input.c:261)
main debug: creating statistics handler
main debug: /Users/larryy/Movies/InnerLifeOfACell.flv' gives access ' demux ' path /Users/larryy/Movies/InnerLifeOfACell.flv'
main debug: creating demux: access= demux= path='/Users/larryy/Movies/InnerLifeOfACell.flv'
main debug: looking for access_demux module: 1 candidate
macosx debug: input has changed, refreshing interface
main debug: creating access path='/Users/larryy/Movies/InnerLifeOfACell.flv'
main debug: looking for access2 module: 6 candidates
vcd debug: trying .cue file: /Users/larryy/Movies/InnerLifeOfACell.cue
access_file debug: opening file `/Users/larryy/Movies/InnerLifeOfACell.flv'
main debug: using access2 module "access_file"
main debug: pre-buffering...
main debug: received first data for our buffer
main debug: pre-buffering done 1408981 bytes in 0s - 458805 kbytes/s
main debug: creating demux: access=
demux= path='/Users/larryy/Movies/InnerLifeOfACell.flv'
main debug: looking for demux2 module: 43 candidates
ffmpeg debug: detected format: flv
access_file error: seeking too far
access_file error: seeking too early
access_file error: seeking too far
main debug: selecting program id=0
ffmpeg debug: adding es: audio codec = mp3
ffmpeg debug: adding es: video codec = undf
ffmpeg debug: AVFormat supported stream
ffmpeg debug: - format = flv (flv format)
ffmpeg debug: - start time = -1
ffmpeg debug: - duration = 189818000
main debug: using demux2 module "ffmpeg"
main debug: looking for a subtitle file in /Users/larryy/Movies/
main debug: looking for decoder module: 25 candidates
ffmpeg debug: libavcodec initialized (interface 3344640 )
ffmpeg debug: ffmpeg codec (MPEG Audio layer 1/2/3) started
main debug: using decoder module "ffmpeg"
main debug: thread 39722496 (decoder) created at priority 37 (input/decoder.c:159)
main debug: looking for decoder module: 25 candidates
main error: no suitable decoder module for fourcc `undf'.
VLC probably does not support this sound or video format.
main debug: killing decoder fourcc `undf', 0 PES in FIFO
main debug: `/Users/larryy/Movies/InnerLifeOfACell.flv' successfully opened
main debug: no aout present, spawning one
main debug: looking for audio output module: 2 candidates
main debug: VLC is looking for: 's16l' 44100 Hz Stereo frame=1 samples/4 bytes
auhal debug: system has [3] device(s)
auhal debug: DevID: 0x118 DevName?: Built-in Microphone
auhal debug: this device is INPUT only. skipping...
auhal debug: DevID: 0x116 DevName?: Built-in Input
auhal debug: this device is INPUT only. skipping...
auhal debug: DevID: 0x11a DevName?: Built-in Output
auhal debug: supported format: [96000][mcpl][12][4][1][4][2][16]
auhal debug: supported format: [88200][mcpl][12][4][1][4][2][16]
auhal debug: supported format: [48000][mcpl][12][4][1][4][2][16]
auhal debug: supported format: [44100][mcpl][12][4][1][4][2][16]
auhal debug: supported format: [96000][mcpl][4][8][1][8][2][20]
auhal debug: supported format: [88200][mcpl][4][8][1][8][2][20]
auhal debug: supported format: [48000][mcpl][4][8][1][8][2][20]
auhal debug: supported format: [44100][mcpl][4][8][1][8][2][20]
auhal debug: supported format: [96000][mcpl][4][8][1][8][2][24]
auhal debug: supported format: [88200][mcpl][4][8][1][8][2][24]
auhal debug: supported format: [48000][mcpl][4][8][1][8][2][24]
auhal debug: supported format: [44100][mcpl][4][8][1][8][2][24]
auhal debug: current format is: [44100][mcpl][41][4][1][4][2][32]
auhal debug: layout of AUHAL has 2 channels
auhal debug: selected 2 physical channels for device output
auhal debug: VLC will output: Stereo
auhal debug: we set the AU format: [44100][mcpl][9][8][1][8][2][32]
auhal debug: the actual set AU format is [44100][mcpl][9][8][1][8][2][32]
main debug: using audio output module "auhal"
main debug: output 'fl32' 44100 Hz Stereo frame=1 samples/8 bytes
main debug: mixer 'fl32' 44100 Hz Stereo frame=1 samples/8 bytes
main debug: no need for any filter
main debug: looking for audio mixer module: 3 candidates
main debug: using audio mixer module "trivial_mixer"
main debug: input 's16l' 44100 Hz Stereo frame=1 samples/4 bytes
main debug: filter(s) 's16l'->'fl32' 44100 Hz->44100 Hz Stereo->Stereo
main debug: looking for audio filter module: 24 candidates
main debug: using audio filter module "s16tofloat32"
main debug: found a filter for the whole conversion
main debug: filter(s) 'fl32'->'fl32' 48510 Hz->44100 Hz Stereo->Stereo
main debug: looking for audio filter module: 24 candidates
main debug: using audio filter module "bandlimited_resampler"
main debug: found a filter for the whole conversion
main debug: control type=1

Change History (4)

comment:1 follow-up: Changed 9 years ago by dionoea

Could you try with a nightly build from http://nightlies.videolan.org ?

comment:2 in reply to: ↑ 1 Changed 9 years ago by larryy

Replying to dionoea:

Could you try with a nightly build from http://nightlies.videolan.org ?

Excellent news... With the latest build (trunk-intel-20061001-0247.dmg), the problem is fixed. (As is an unrelated problem with VLC closing certain flash movies when rewound, that I was trying to characterize before writing up.) And there were no lags or dropped frames (that were noticeable anyway) in VLC's playback, unlike any other stand-alone player. Kudos!

Unless I hit a problem of some kind, it looks like I'll just switch to using this build.

comment:3 Changed 9 years ago by dionoea

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 9 years ago by haffy

I get this with the nightly build:

No suitable decoder module for format VLC probably does not support the "undf" audio or video format. Unfortunately there is no way for you to fix this.

trunk-intel-20061210-0058.dmg

Note: See TracTickets for help on using tickets.