Opened 3 years ago

Closed 3 years ago

#7185 closed enhancement (fixed)

Add support for decoding new audio format: Opus

Reported by: teddy Owned by: jb, fkuehne
Priority: normal Milestone: 2.0.4
Component: Decoders Version: master git
Severity: normal Keywords:
Cc: Difficulty: unknown
Platform(s): all Work status: Not started

Description

New audio format: Opus Interactive Audio Codec

Example: http://people.xiph.org/~giles/2012/opus/ehren-paper_lights-64.opus

Website: http://opus-codec.org/

Change History (5)

comment:1 Changed 3 years ago by courmisch

  • Component changed from Unknown to Decoders
  • Milestone changed from Bugs paradize to Features paradize

comment:2 follow-up: Changed 3 years ago by jb

  • Milestone changed from Features paradize to 2.1 features

This is high priority and gmaxwell has a patch for it.

comment:3 in reply to: ↑ 2 Changed 3 years ago by bat_guano

Replying to jb:

... gmaxwell has a patch for it.

Hi

The patch has been applied ---> http://git.videolan.org/?p=vlc.git;a=commit;h=7258c97afdf6e8209a1be5c8ce707e6040c38454

But it doesn't seem to be working.

My FFmpeg is compiled with libopus and I can play opus files with FFplay.

Is there something else needed for VLC?

Message is:-

[0x9fecfd8] main decoder error: no suitable decoder module for fourcc `Opus'.

VLC probably does not support this sound or video format.

[0x9fecfd8] main decoder error: No suitable decoder module

[0x9fecfd8] main decoder error: VLC does not support the audio or video format "Opus". Unfortunately there is no way for you to fix this.

Ubuntu-11.04

VLC media player 2.1.0-git Rincewind (revision cfb1f18)

Last edited 3 years ago by bat_guano (previous) (diff)

comment:4 Changed 3 years ago by jb

No, this is the demuxer part, not the decoder.

comment:5 Changed 3 years ago by jb

  • Milestone changed from 2.1 features to 2.0.4
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.