Opened 4 years ago

Closed 3 years ago

#6206 closed defect (fixed)

make fails with Lua escape sequence error

Reported by: johndoe32102002 Owned by: ivoire, linkfanel
Priority: normal Milestone: Bugs paradize
Component: LUA scripts Version: 2.0.0
Severity: normal Keywords: lua, invalid escape sequence
Cc: johndoe32102002@… Difficulty: unknown
Platform(s): all Work status: Not started

Description

System: Ubuntu 11.10 x64 VLC: 2.0.0

luac -v Lua 5.2.0 Copyright (C) 1994-2011 Lua.org, PUC-Rio

make ... LUAC lua/playlist/appletrailers.luac /usr/local/bin/luac: lua/playlist/appletrailers.lua:70: invalid escape sequence near '\.' make[2]: * [lua/playlist/appletrailers.luac] Error 1

Background: The ./configure ran with no errors. libvlc configuration - version : 2.0.0 system : linux architecture : x86_64 mmx sse sse2 optimizations : yes vlc aliases : cvlc rvlc

Change History (3)

comment:1 Changed 4 years ago by jb

  • Component changed from Unknown to LUA scripts
  • Owner changed from jb to ivoire, linkfanel

I suspect this is a 5.2 issue

comment:2 Changed 3 years ago by johndoe32102002

I changed systems and have the same error. System: Slackware 13 x64

lua -v Lua 5.2.0 Copyright (C) 1994-2011 Lua.org, PUC-Rio

gcc --version gcc (GCC) 4.7.0

LUAC lua/playlist/appletrailers.luac

/usr/local/bin/luac: lua/playlist/appletrailers.lua:70: invalid escape sequence near '\.' make[2]: * [lua/playlist/appletrailers.luac] Error 1

comment:3 Changed 3 years ago by linkfanel

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.