Opened 4 years ago

Closed 4 years ago

#5477 closed defect (fixed)

VLC nightly does not display subtitles in 10bit videos

Reported by: reloc0 Owned by: jb
Priority: normal Milestone: Bugs paradize
Component: Subtitles Version: master git
Severity: normal Keywords: subtitles mkv 10bit
Cc: cruzki123@… Difficulty: unknown
Platform(s): Linux Work status: Not started

Description

I searched the bugtracker but didn't find my problem has already been reported.

I use the nightly build from https://launchpad.net/~videolan/+archive/master-daily for ubuntu 11.10 . When playing some mkv files with subtitles, the subtitles are missing. the console says

[0x2c02068] main blend error: blending RGBA to I0AL failed and [0x2c02068] main blend error: blending YUVA to I0AL failed

The Files this happens at are 10bit. I found some bugs that have the subtitles displayed as wrong colors but they are not at all being displayed for me.

Change History (8)

comment:1 Changed 4 years ago by courmisch

Hmm, yeah. There is simply no code to blend RGBA and YUVA to 9-bits and 10-bits.

comment:2 Changed 4 years ago by fenrir

Forcing opengl/direct3d output will workaround the issue.

comment:3 Changed 4 years ago by jb

D3D works fine.

comment:4 Changed 4 years ago by https://launchpad.net/~sebner

I'm using ubuntu 11.10 and the nightly PPA too. Forcing opengl made the video ouput black so I reverted that *but* changing the Deinterlacing setting from "Off" to "Automatic" fixed the issue for me.

EDIT: Ignore my post. It's still working even if I change it back to "Off" again. Dunno what's really going on. Output is "Default" (forcing opengl output definitely doesn't work though)

Last edited 4 years ago by https://launchpad.net/~sebner (previous) (diff)

comment:5 Changed 4 years ago by https://www.google.com/accounts/o8/id?id=aitoawl36j02xzddxvnphwfky6toosrqbwh5ngu

I had the same problem and I was able to resolve by setting video output to GLX Video Output (XCB).

I'm running Linux 64-bit with snapshot builds of VLC and libx264. I have Ubuntu 11.10 repository builds of libxcb.

comment:6 Changed 4 years ago by jb

Should we make opengl the default on Linux then?

comment:7 Changed 4 years ago by http://cruzki.myopenid.com/

  • Cc cruzki123@… added

comment:8 Changed 4 years ago by ILEoo

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.