Opened 4 years ago

Closed 4 years ago

#5298 closed defect (fixed)

Wrong cover art displayed if either Album tag OR Artist tag are missing

Reported by: Lotesdelere Owned by: funman
Priority: normal Milestone: 2.0.0 bugs
Component: Core: Playlist Version: master git
Severity: normal Keywords: cover art tag album
Cc: funman Difficulty: unknown
Platform(s): all Work status: Not started

Description

As reported in this thread: http://forum.videolan.org/viewtopic.php?f=2&t=79717&start=20#p306636

There is a bug in VLC with embedded cover art when there is no Album tag set.
In this case, the first tagged file with no Album tag set being opened in VLC will create a sub folder "/art/arturl/254ee9553243878e0f06dfea051798eb" and will drop there the cover art. Then, any and every other tagged file which has no Album tag set will use this cover art without renewing / refreshing the content of this sub folder nor creating a new sub folder.

However some files with a malformed Album tag as seen in this thread http://forum.videolan.org/viewtopic.php?f=14&t=93740&p=310267#p310267 won't use this cached arturl cover for some reason.

Change History (17)

comment:1 Changed 4 years ago by courmisch

  • Component changed from Demuxers to Core: Playlist
  • Milestone changed from Bugs paradize to 1.2 bugs

comment:2 Changed 4 years ago by jb

  • Owner changed from fenrir to ivoire

This is highly annoying.

comment:3 Changed 4 years ago by svnpenn

To be more correct, it is the Album AND Artist tag. When both are set, VLC creates this

AppData\Roaming\vlc\art\artistalbum\[Artist]\[Album]\art.jpg

If either the Artist or Album tags are missing, then it refers to the picture under arturl

Last edited 4 years ago by svnpenn (previous) (diff)

comment:4 Changed 4 years ago by Lotesdelere

Also look at #5309 which is linked to this one.

Last edited 4 years ago by Lotesdelere (previous) (diff)

comment:5 Changed 4 years ago by jb

Test

Here is some samples (Lotesdelere made them): http://streams.videolan.org/issues/5298/CoverArt.tar.xz

Same metadata, but CoverArt? different and filename different.

Delete your cache art folder, and play the first. Play the second and it will use the same CoverArt?.

Do the same in the reverse order and you'll see the other cover art on both.

This is wrong.

Quick Analysis

There are at least 2 bugs here:

1) We should use the filename or URI for art_cache ID

2) We should first READ in the file for cover Art, THEN, look in the cache folder and FINALLY, on the internet.

comment:6 Changed 4 years ago by jb

  • Cc funman added

comment:7 Changed 4 years ago by funman

First, the 2 files in the .xz are identical.

Here's how art works: Same Artist, same Album => same Art.

We look for a cached image (using Artist and Album metadata), if found we use it. If not found, we extract it from metadata and cache it. If not found from metadata we "download" it.

Download can come from local file (cover.jpg, AlbumArtSmall?.jpg, .folder.png, Folder.jpg, user-specified name), or if it didn't work, lua scripts.

google image use artist/album/title frenchtv use 1 image per known URL for a list of channels lastfm and musicbrainz use artist/album.

So if you have files with same metadata but different art (looks wrong to me but...) and you want to use the art from the file if available here's what we should do:

Cache the art unconditionally if attachments are present since qt4 only displays a file

Pretty much defeats the concept of a cache, doesn't it?

comment:8 Changed 4 years ago by https://www.google.com/accounts/o8/id?id=aitoawn9y_cz23ovzmsc9bu58rqjaex3dyrtus8

Ok funman has sadly missed the point.

as I stated earlier, and as is stated in the ticket:

There is a bug if there is no Album OR Artist tag set. Please lets stick to the issue at hand.

comment:9 Changed 4 years ago by funman

Indeed what jb describes is not what the ticket description says.

So can you share a sample to reproduce the bug?

Here files without the album field set get no album art.

comment:10 Changed 4 years ago by jb

First, the 2 files in the .xz are identical.

Crap, there are supposed to be different. Same tags, but different cover...

Cache the art unconditionally if attachments are present since qt4 only displays a file.

It can be different, since Qt accepts any QByteArray for Image source. And this must be fixed for mkv cover art to work.

comment:11 Changed 4 years ago by https://www.google.com/accounts/o8/id?id=aitoawn9y_cz23ovzmsc9bu58rqjaex3dyrtus8

jb, please stay on topic. For the second time, this ticket is about files with missing Album OR Artist tag, not some other issue.

comment:12 Changed 4 years ago by jb

I do what I want.

If you want the topic to be more precise, then make the subject of the bugreport more clear.

And what I was saying is EXACTLY in the "Wrong cover art displayed".

comment:13 Changed 4 years ago by jb

  • Summary changed from Wrong cover art displayed to Wrong cover art displayed if either Album tag OR Artist tag are missing

Correct issue name.

comment:14 Changed 4 years ago by funman

instead of bitching and repeating what the subject is will you give me samples?

I just need 2 mp3 to reproduce the problem it seems

comment:15 Changed 4 years ago by svnpenn

ok for mp3 files the culprit file is

%appdata%/vlc/art/arturl/c6b8426f1ccb4235d6fefa6f5a2df46b/art

sample files at

http://svnpenn.github.com

Last edited 4 years ago by svnpenn (previous) (diff)

comment:16 Changed 4 years ago by funman

  • Owner changed from ivoire to funman
  • Status changed from new to assigned

thanks, i can reproduce it

comment:17 Changed 4 years ago by funman

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.