Opened 4 years ago

Closed 23 months ago

#5242 closed defect (notvlc)

Playback of files with b-frames is corrupt

Reported by: maldata Owned by:
Priority: normal Milestone: Bugs paradize
Component: Decoders Version: 1.1.11
Severity: normal Keywords: b-frames
Cc: Difficulty: unknown
Platform(s): all Work status: Not started

Description

Since upgrading ffmpeg from 0.7_rc1 to 0.7.3 and VLC from 1.1.10 to 1.1.11, playback of files encoded with b-frames is corrupt.

I encoded a file once with b-frames, once without. The source file plays back fine. Playing the two output files back in VLC 1.1.11, the file encoded with b-frames has corrupted video. The same file played in totem looks fine.

This is also reported in https://ffmpeg.org/trac/ffmpeg/ticket/28 but I'm not sure if the problem is VLC or the ffmpeg decoder.

I have only tried it with files I encoded to xvid. I am running Gentoo linux x86_64.

Change History (2)

comment:1 Changed 4 years ago by jb

This is very likely a FFmpeg regression, since there are absolutely no changes in decoder between .10 and .11

comment:2 Changed 23 months ago by jb

  • Resolution set to notvlc
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.