Opened 5 years ago

Closed 5 years ago

Last modified 15 months ago

#3820 closed defect (fixed)

webm files cannot be played. no suitable decoder module for fourcc 'VP80'.

Reported by: wonder Owned by: jb, xtophe
Priority: high Milestone: 2.0.0 bugs
Component: Build system: Contribs Version: master git
Severity: normal Keywords:
Cc: Difficulty: unknown
Platform(s): Linux Work status: Not started

Description

vlc 1.1.0

ffmpeg from subversion, revision 23792, libvpx and native decoder built in.

> ffmpeg -codecs 2> /dev/null | grep -i vp8
 DEV    libvpx          libvpx VP8
 D V D  vp8             On2 VP8

> ffmpeg -formats 2> /dev/null | grep webm
  E webm            WebM file format

Attachments (1)

log.log (23.7 KB) - added by wonder 5 years ago.
vlc -vv log

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by wonder

vlc -vv log

comment:1 Changed 5 years ago by ILEoo

Seems to be more libavcodec native decoder issue, it doesn't seem to work with CODEC_FLAG_EMU_EDGE codec flag (vlc sets this in direct rendering setup). --no-ffmpeg-dr helps to workaround this bug.

comment:2 Changed 5 years ago by courmisch

  • Component changed from Decoders to Contribs
  • Owner set to jb, xtophe

comment:3 Changed 5 years ago by ILEoo

  • Resolution set to fixed
  • Status changed from new to closed

[73339d95a75f7f9311d4aa8674ee2600f884d8d7] should workaround this

comment:4 Changed 15 months ago by jb

  • Milestone changed from Bugs paradize to 2.0.0 bugs
Note: See TracTickets for help on using tickets.