Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#3685 closed defect (fixed)

Distorted audio in DV file

Reported by: ssp Owned by:
Priority: normal Milestone: Bugs paradize
Component: Decoders Version: master git
Severity: normal Keywords:
Cc: Difficulty: unknown
Platform(s): all Work status: Not started

Description

When playing a DV file the audio is badly distorted, with the distortion being mainly in the right audio channel.

I am hearing this in all the DV files I have (which all come from the same camera) with both VLC 1.0.5 and 1.1-RC (on an Intel-Mac). QuickTime? plays the audio in these DV files just fine.

Example file: http://dl.dropbox.com/u/382997/VLC/Original.dv (~80MB)

The audio in the file is sampled at 32kHz

As a further experiment I tried is to open that file in QuickTime? an then re-save it to DV with the audio re-sampled to 44,1kHz. The resulting file

http://dl.dropbox.com/u/382997/VLC/Original-44kHz.dv

plays fine in VLC, which leads me to suspect that this has something to do with the sampling rate.

(copied from the forum: http://forum.videolan.org/viewtopic.php?f=12&t=76903)

Change History (13)

comment:1 Changed 5 years ago by ssp

  • Summary changed from Distored audio in DV file to Distorted audio in DV file

comment:2 follow-up: Changed 5 years ago by ajmas

Could you please specify Mac model and MacOS X version?

comment:3 in reply to: ↑ 2 Changed 5 years ago by ssp

Replying to ajmas:

Could you please specify Mac model and MacOS X version?

Sure. It's a late 2008 MacBook? Core2Duo 2,1GHz (MacBook4,1) on Mac OS 10.6.

comment:4 follow-up: Changed 5 years ago by jb

I don't have the issue with the latest NB.

comment:5 in reply to: ↑ 4 Changed 5 years ago by ssp

Replying to jb:

I don't have the issue with the latest NB.

Odd. I downloaded the latest build I could find ( http://nightlies.videolan.org/build/macosx-intel/1.1-branch-intel64-20100526-0209.zip ) and I'm still having the problem with the Original.dv file there.

Is there any newer build available?

comment:6 Changed 5 years ago by ssp

FWIW, I can add the following:

  1. I tried the older 1.0.3 and 0.9.10 versions of VLC and got exactly the same behaviour there, so this doesn't seem to be a new issue.
  1. I googled the topic and this forum thread https://88.191.250.119/viewtopic.php?f=14&t=16130&start=0 sounds quite similar (DV, 32kHz audio, one channel affected). This Apple forum post also tangentially mentions a similar effect: http://discussions.apple.com/message.jspa?messageID=10075858 .

comment:7 Changed 5 years ago by ssp

I'll add some more information.

  1. I tried playing the DV file in question using ffplay on a Linux machine and the sound did play correctly there.
  2. I tried opening the DV file with VLC using —access ffmpeg but that didn't improve things.
  3. When fooling around with the DV file with ffmpeg, I noticed that it contains two stereo sound tracks (which seems to be normal for 32kHz DV audio). Yet, VLC only lists one of them in the video information. Could that be related to the problem I am having?

comment:8 Changed 5 years ago by ssp

In case that helps your analysis of the issue: I figure out that I can 'fix' the files by converting them to 48kHz audio using

ffmpeg -i Original.dv -target dv Fixed.dv

first and then opening them with VLC.

So this provides a (somewhat slow) workaround.

comment:9 Changed 3 years ago by fenrir

Could you upload the samples again?

comment:10 Changed 3 years ago by ssp

The old links should be working again now.

comment:11 Changed 3 years ago by jb

Thanks a lot. Mirror here: http://streams.videolan.org/issues/3685/

comment:12 Changed 3 years ago by fenrir@…

  • Resolution set to fixed
  • Status changed from new to closed

commit 47b27a1e4a05571f280e7e04e026857311be67cd Author: Laurent Aimar <fenrir@…> Date: Wed May 30 01:01:21 2012 +0200

Fixed DV audio using 12 bits quantization.

It close #4828 and #3685.

comment:13 Changed 3 years ago by philippe cloutier

I am far from an expert on DV, but if I look at the codec information given by VLC, it seems the file given as testcase is 16-bit, not 12-bit.

In any case, I can confirm that VLC 2.1 nightlies fix the problem on a Windows machine which had 2.0. Strangely, different 2.0 installs seem to give very different results. 2.0.3 on Debian gives very distorted but still comprehensible audio, while on Windows the audio was worthless. This problem affected all video recorded with my Sony Handycam DCR-HC30.

Note: See TracTickets for help on using tickets.